Skip to main content

View Post [edit]

Poster: Harry Wilson Date: May 13, 2018 2:04pm
Forum: oldtimeradio Subject: Chrome / Android Problems On Audio Page

There is a page with 122 audio files on it, but only 10 will play in the online player, in the Chrome browser. They work fine in IE, Firefox, and Edge. Here's the page:
https://archive.org/details/OTRR_X_Minus_One_Singles


There are five recent comments that mention the problem; the two that specify Android issues are both from April, so Android may not be a problem any more. Someone with a cell phone can check that out.

I peeked behind the curtain ("Show All") and looked through the files there, and couldn't see any difference between the mp3s that play and those that don't, but my computer knowledge is nil.


These are the ten files that will play in Chrome; I don't know if they work in Android. The number is their number in the player:

3 - Mars Is Heaven

35 - The Parade

39 - Junkyard

41 - A Gun For Dinosaur

44 - A Pail Of Air

58 - Mr. Costello, Hero

70 - Colony

76 - There Will Come Soft Rains

89 - The Seventh Victim

117 - The Haunted Corpse


Thanks, Admins.

-------------------------------------

P.S. I forgot to mention that if you expand the 'MP3' list under download options, then click the mp3 file name to play it right in the Chrome browser, the same 10 will work; the other 112 won't. I'm guessing this means it's an issue with the files, not the player.

However, if you expand the 'OGG VORBIS' list and click the file names to play them in the browser, all 122 of them seem to work just fine.

P.P.S. Happy Mothers' Day, y'all!


This post was modified by Harry Wilson on 2018-05-13 21:04:53

Reply [edit]

Poster: Harry Wilson Date: Aug 28, 2018 2:38pm
Forum: oldtimeradio Subject: Chrome / Android Problems On Audio Page (Again) - Update (With A Clue)

It's doing 'that thing' again.

This problem was the subject of the May 13th parent posts, and it got fixed, but now the same problem has returned.

There is a page with 122 audio files on it, but in the Chrome browser, only 10 will play in the online player or by clicking the name in the 'MP3' dropdown list. If you click the file names under the 'OGG VORBIS' dropdown list, all 122 of those play fine in Chrome.

All of the files work fine in IE, Firefox, and Edge. Here's the page:
https://archive.org/details/OTRR_X_Minus_One_Singles


As with before, these are the ten files that will play in Chrome (I don't know if they work in Android, but there are comments on the page about Android problems). The number is their number in the player:

3 - Mars Is Heaven

35 - The Parade

39 - Junkyard

41 - A Gun For Dinosaur

44 - A Pail Of Air

58 - Mr. Costello, Hero

70 - Colony

76 - There Will Come Soft Rains

89 - The Seventh Victim

117 - The Haunted Corpse


-----------------------------------------

UPDATE:

Reader's Digest version: I think the mp3 metadata tags are screwing up Chrome.


I found one more page with the same issue, among my own uploads. I checked all of my pages in Chrome, and found a page with five audio files, one of which displays the "Error loading media: File could not be played" message. Here's the url; the first mp3 file is the dud:
https://archive.org/details/itotr-amosandandy-mister1943

I downloaded the mp3 that wasn't working and compared it to the original that I uploaded, and they were the same, down to the last byte. I then uploaded the mp3 file saved from the Amos & Andy page, as well as my original mp3 which had never been on IA, to my practice page. On that page, neither file would play, with both giving the same error message.

I made two other versions of my original file, one with no metadata tags, and the other with a shorter file name. EUREKA! Of the four versions, only the one with no tags plays in Google Chrome.

Here's my practice page that I uploaded the different versions to; the happy file is #4 in the player:
https://archive.org/details/harryspracticepage20160825

The one possible fly in the ointment is that the fourth mp3 on my A&A page has nearly identical metadata, and it works like a charm.

P.S. I don't know if it's related, but the Amos & Andy page that's having the problem is also the only one of my thirty-six audio uploads that's not affected by the hyperactive views counter issue.


Thanks, Admins.


This post was modified by Harry Wilson on 2018-08-28 21:38:23

Reply [edit]

Poster: Jeff Kaplan Date: May 13, 2018 4:26pm
Forum: oldtimeradio Subject: Re: Chrome / Android Problems On Audio Page

bug report filed. thank you.

Reply [edit]

Poster: Harry Wilson Date: May 18, 2018 5:23pm
Forum: oldtimeradio Subject: Re: Chrome / Android Problems On Audio Page

Everything seems good now; many thanks to all concerned!